Known issues migrating Pushwoosh Flutter Plugin to version 2.1.0 or higher
If you are facing errors building your Android application after updating Pushwoosh Flutter Plugin to version 2.1.0 or higher, please search this guide for the error you encountered and follow the instructions to fix.

Build error:

In project 'app' a resolved Google Play services library dependency depends on another at an exact version (e.g. "[17.0.0, 18.0.99]", but isn't being resolved to that version. Behavior exhibited by the library will be unknown.
Solution:
Add this line to your app/build.gradle file:
1
googleServices { disableVersionCheck = true }
Copied!
Build error:
The minCompileSdk (30) specified in a dependency's AAR metadata (META-INF/com/android/build/gradle/aar-metadata.properties) is greater than this module's compileSdkVersion (android-29).

Solution:

Update compileSdkVersion in your app/build.gradle file:
1
android {
2
compileSdkVersion 30
3
...
Copied!

Build error:

AAPT: error: unexpected element <queries> found in <manifest>.

Solution:

Update gradle plugin in your project. To do this, open PROJECT_DIR/build.gradle and update gradle plugin version to version 4 or higher:
1
classpath 'com.android.tools.build:gradle:4.1.2'
Copied!
In PROJECT_DIR/gradle/wrapper/gradle-wrapper.properties, update gradle wrapper version:
1
distributionUrl=https\://services.gradle.org/distributions/gradle-6.1.1-all.zip
Copied!

Build error:

After updating gradle plugin to version 4 or higher, you may also face a known build error https://issuetracker.google.com/issues/158753935?pli=1
Transform's input file does not exist: /build/app/intermediates/flutter/debug/libs.jar.

Solution:

Change this in your app/build.gradle file
1
lintOptions {
2
disable 'InvalidPackage'
3
}
Copied!
to this:
1
lintOptions {
2
checkReleaseBuilds false
3
}
Copied!
Last modified 2mo ago
Copy link